CentOS7安装RabbitMQ 3.8.0

文章目录

折腾了两天总算把RabbitMQ安装上了,中途遇到了不少坑,主要原因为Erlang没有安装对,因为在安装Erlang时即便缺少了一些依赖,也可以安装成功Erlang,但后面安装RabbitMQ后就不能成功启动RabbitMQ。

安装版本准备

RabbitMQ是Erlang语言编写的,安装RabbitMQ之前,需要先安装Erlang。但安装Erlang前,需要先安装Erlang的依赖。

安装Erlang依赖

#安装gcc,c++,gtk2+环境
yum install gcc g++ gcc-c++ gdb make
yum -y install gtk2 gtk2-devel gtk2-devel-docs

#安装相应依赖包
yum install openssl yum install openssl-devel
yum install fop fop-devel
yum install unixODBC-devel
yum install  ncurses-devel


#安装asn1
wget https://ftp.gnu.org/gnu/libtasn1/libtasn1-4.13.tar.gz
tar zxvf libtasn1-4.13.tar.gz 
cd libtasn1-4.13
./configure --prefix=/usr --disable-static && make
make install

#安装opengl
yum list mesa* 
yum install mesa*  

#安装glk2.0+
yum install libgnomeui-devel


#安装wxWidgets
wget https://github.com/wxWidgets/wxWidgets/releases/download/v3.0.4/wxWidgets-3.0.4.tar.bz2
yum install bzip2
tar -xjf wxWidgets-3.0.4.tar.bz2
cd wxWidgets-3.0.4
./configure --with-opengl --enable-debug --enable-unicode
make
make install

安装Erlang

安装Erlang时,要先选对版本。
版本对照可以查看RabbitMQ的官网:
https://www.rabbitmq.com/which-erlang.html

这里打算安装最新的3.8.0版本的RabbitMQ,那么就要安装Erlang 22.1版本。
Erlang安装包官网下载地址:http://erlang.org/download/

wget http://erlang.org/download/otp_src_22.1.tar.gz
tar -zxvf otp_src_22.1.tar.gz
cd otp_src_22.1
./configure --without-javac
#此处如果配置报错:jinterface     : Java compiler disabled by user,那么就去掉--without-javac再试试。试之前确保javac命令可用,如果不可用就安装下:yum install java-1.8.0-openjdk-devel.x86_64
make && make install

到此,Erlang安装完成,直接输入erl,得到如下图得安装成功

安装RabbitMQ Server

获取rpm的下载地址:https://www.rabbitmq.com/download.html

wget --content-disposition https://github.com/rabbitmq/rabbitmq-server/releases/download/v3.8.0/rabbitmq-server-3.8.0-1.el7.noarch.rpm
rpm -ivh rabbitmq-server-3.8.0-1.el7.noarch.rpm
#如果提示erlang >= 21.3 is needed by之类的信息,则试试在后面加上:--nodeps

#启动rabbitmq-server
systemctl start rabbitmq-server

# 后台启动rabbitmq服务
rabbitmq-server -detached

#查看状态
rabbitmqctl status

#列出用户
rabbitmqctl list_users

#添加用户
rabbitmqctl  add_user admin admin

#设置用户类型
rabbitmqctl set_user_tags admin administrator

#重启rabbitmq-server
systemctl restart rabbitmq-server

#查看rabbit启动信息
journalctl -xe


#查看wxWidgets是否安装成功
wx-config --version

#开启远程管理界面插件
rabbitmq-plugins enable rabbitmq_management
#启用了rabbitmq的管理插件,会有一个web管理界面,默认监听端口15672,将此端口在防火墙上打开,则可以访问web界面:

简易安装方法

除了以上较为复杂的安装方法外,还有更简单的安装方法,但该方法只能安装最新版本的rabbitmq,不能指定版本。只需要按顺序依次执行以下命令即可:

#安装Erlang
curl -s https://packagecloud.io/install/repositories/rabbitmq/erlang/script.rpm.sh | sudo bash
yum  -y install erlang
#安装rabbitmq
curl -s https://packagecloud.io/install/repositories/rabbitmq/rabbitmq-server/script.rpm.sh | sudo bash
yum -y install rabbitmq-server

参考:https://blog.csdn.net/weixin_41004350/article/details/83046842

https://blog.csdn.net/hnyzlsw_645/article/details/81225872

发表评论

电子邮件地址不会被公开。 必填项已用*标注